non-Latin characters: Problem with Arabic letters

Post here if you have problems installing or using doPDF.
Mutarjim
Posts: 1
Joined: Mon Feb 16, 2009 11:15 am

Postby Mutarjim » Mon Feb 16, 2009 6:24 pm

First of all thank you very much for this application, and for offering doPDF free.


My question is related to documents including Arabic words or fully writen in Arabic language.


Apparently doPDF does not recognise most of the Arabic characters and the layout od the document is not respected.


I hope that in a following version this problem will be solved.

Thanks for considering this feedback.



Softland
Posts: 1466
Joined: Thu May 23, 2013 7:19 am

Postby Softland » Mon Feb 16, 2009 7:06 pm

dopdf should work fine with arabic documents too (just do a test on a website with arabic text), so there must be a problem with the document you've tested. Is it possible to send a document you tested and didn't work correctly to info[at]dopdf[dot]com (we need the document in the original format, and also the output that you obtained)?



mike.bch
Posts: 1
Joined: Sat Mar 28, 2009 4:59 pm

Postby mike.bch » Sat Mar 28, 2009 11:06 pm

I have similar problem with printing in French. Accented French letters, like é, â print out like question marks

I tried several pages, like leparisien.fr. Just open any article and click the print button (to the side of the text).

I am using international english keyboard. I mean, I can print this accented chars. I also have French keyboard installed.

I am using Windows XP Home edition with Hebrew enabled.



Softland
Posts: 1466
Joined: Thu May 23, 2013 7:19 am

Postby Softland » Mon Mar 30, 2009 11:44 am

mike, try also printing from a different browser; and another test you could do is printing but checking the Embed fonts option too.



mutaryim
Posts: 5
Joined: Fri Jul 03, 2009 6:09 am

Postby mutaryim » Fri Jul 03, 2009 2:20 pm

Sorry I forgot to check the answers you gave me, please see this post for the samples:


http://www.dopdf.com/forum/topic/dopdf-and-the-caption-of-arabic-scripts#post-850


if you need further samples (or from MS Word also) please contact me al:


mutaryimATgmailDOTcom



mutaryim
Posts: 5
Joined: Fri Jul 03, 2009 6:09 am

Postby mutaryim » Fri Jul 03, 2009 2:23 pm

I forgot to say that I use the Firefox browser (Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11).


Should I try the MS Explorer or Google Chrome?



Softland
Posts: 1466
Joined: Thu May 23, 2013 7:19 am

Postby Softland » Fri Jul 03, 2009 2:50 pm

Try printing from MS Explorer too, and check what option you have selected in View-Encoding (if it's not, try selecting UTF-8); seems strange that it doesn't convert the characters. Also, what's the url for the second example you gave in the other post?



mutaryim
Posts: 5
Joined: Fri Jul 03, 2009 6:09 am

Postby mutaryim » Sat Jul 04, 2009 3:45 am

These are the URLs


for the 1st webpage (Spanish with some Arabic words):


telefonica.net/web2/jmtru/arabe/quecae.html


I tried other view encodings (Arabic standards) and the Arabic letters are well captured when printing from this webpage, but there are some letters from the Spanish text that are not well viewed (on the screen and in the print).


for the 2nd webpage (fully in Arabic):


al-fateh.net/fateh-d/fa-09-151/farha.htm


I tried printing the second one from MS Explorer but I had the same problem. And when selecting UTF-8 enconding in the MS EXplorer, the web page turns into a blank page (everything disappears). In the Firefox, when switching to the UTF-8 encoding view, I get funny characters instead the Arabic text. I get this:


������

Hopefully you can help me :-(




Return to “Troubleshooting”